Einführung

HTML-Hilfe für jk-ware Theater 4.0

jk-ware Theater für Windows

HTML-Hilfe Hyperlinks:

Erläuterungen

Unter jk-ware Theater können Blocker Ebenen, Color LIFE Sound und Perpetuum mobile mehrfach aufgerufen werden und gleichzeitig ablaufen.

Jedes Spiel kann die Größe des Rahmenfensters zum Teil oder ganz einnehmen oder sich mit den anderen Spielen den Platz teilen.

Die Spielfenster werden über den Menüpunkt "Fenster" überlappend, nebeneinander oder übereinander angeordnet.

Sinn und Zweck von Theater ist es spielerisch die Leistungsfähigkeit des Computers zu erproben. Die hierbei ausgewählten Fensteranordnungen können zur späteren Wiederherstellung als Konfigurationen abgespeichert werden.

Der Ablauf im Einzelnen

jk-ware Theater ist ein Rahmenprogramm in dem die Spielprogramme von jk-ware als MDI-Fenster gestartet werden können (MDI = Multiple Document Interface).

Jedes Programm läuft unter Windows™ als einzelne Aufgabe (Thread) und erhält dadurch abwechselnd mit den anderen Programmen den Mikroprozessor für eine kleine Zeitdauer zugeteilt.

Hierdurch ergibt sich auf Computern mit einem Prozessorkern nur scheinbar ein gleichzeitiger Ablauf der Spiele.

Nur auf Systemen mit Mehrkern-Prozessoren wird idealer weise jedem Programm ein Prozessorkern zugeteilt, wodurch die Spiele gleichzeitig ablaufen.

Einschränkungen

Windows™ stellt nur eine begrenzte Kapazität an System-, Benutzer- und Grafik-Ressourcen zur Verfügung. Wenn diese aufgebraucht sind kann kein weiteres Spiel mehr gestartet werden.

Blocker Ebenen und Perpetuum mobile benötigen viele Ressourcen von Windows, so dass nur einige Instanzen der Programme gleichzeitig ablaufen können.

Color LIFE Sound benötigt wenige Ressourcen, dafür aber bei großen Generationen einigen Speicherplatz des Computers.

Auf neuen PC-Systemen mit Windows™ 7 oder nachfolgenden Betriebssystemen treten diese Probleme erst bei vielen aufgerufenen Programmen auf.
Dieses wird auch bei den von jk-ware bereitgestellten Theater-Konfigurationen berücksichtigt.

Bei andauernden Ablaufproblemen kann die Ursache auch bei den Treibern für die Sound- und Grafikkarte liegen, wenn diese nicht für multithreading geeignet sind.

Umgang mit den Konfigurationsdateien

Die Konfigurationsdateien enthalten die Registrierungsdaten unter „HKEY_CURRENT_USER\Software\jk_ware\Theater\4.0\Konfig“. Durch „Programm\Auswahl\Speichern...“ werden diese Daten in eine *.cfg-Datei geschrieben. Beim Laden mit „Programm\Auswahl\Laden...“ werden die Daten unter den obigen Registrierungsschlüssel eingelesen.

Achtung ! Beim Einlesen einer neuen Konfigurationsdatei geht der aktuelle Spielaufbau unwiederbringlich verloren.

Wenn Spieldaten wie die Rangliste von Blocker Ebenen oder die aktuellen Rechenregeln zum Suchen von schönen Color LIFE-Mustern erhalten bleiben sollen, müssen diese in eine Konfigurationsdatei abgespeichert werden, bevor sie durch eine neue überschrieben werden.

Eine Veränderung der Registrierungsdaten sollte nur von Theater selbst vorgenommen werden!

jk-ware, Dipl.-Ing. Reinhard Jakob

HTML-Hilfe frei kopierbar

™ Windows ist eine eingetragene Marke der Microsoft Corporation


HTML-Hilfe für jk-ware Theater 4.0
Nach oben

Menüauswahl

Programm-Menü

Blocker Ebenen!
Color LIFE Sound!
Perpetuum mobile!

Über diese Menüpunkte starten Sie die Spiele von Blocker Ebenen, Color LIFE Sound und Perpetuum mobile.

Auswahl >

Wiederherstellen

stellt die letzte Auswahl oder den zuletzt eingelesenen oder abgespeicherten Spielaufbau wieder her.

1 x BLE, 1 x CLS, 1 x PPM

schließt alle offenen Fenster und startet je einmal Blocker Ebenen, Color LIFE Sound und Perpetuum mobile.

2 x CLS, 2 x PPM

startet zusätzlich je zweimal Color LIFE Sound und Perpetuum mobile.

4 x Color LIFE Sound

öffnet weitere vier Fenster von Color LIFE Sound

4 x Perpetuum mobile

es werden weitere vier Spiele von Perpetuum mobile gestartet

Laden ...

das Dialogfenster „Öffnen“ zur Auswahl eines Spielaufbaus aus einer Konfigurationsdatei (*.cfg) für jk-ware Theater wird angezeigt.

Speichern ...

öffnet das Dialogfenster „Speichern unter“ zum Abspeichern des Spielaufbaus in eine Konfigurationsdatei (*.cfg) für jk-ware Theater.

Anm.: Konfigurationsdateien können nur dann geladen und abgespeichert werden, wenn das Programm als Administrator ausgeführt wird.

Alle Pause / Start

Der Zustand von allen Programmen wechselt hierdurch von Pause zu Start und umgekehrt.

Bildschirmschoner

Wenn markiert, ist jk-ware Theater als Bildschirmschoner ausgewählt. Der Bildschirmschoner und die Monitorabschaltung unter Windows™ sind dadurch ausgeschaltet.

Alle Fenster Schließen!

Schließt alle Fenster innerhalb von jk-ware Theater.

Ende!

Schließt alle Rahmenfenster und beendet jk-ware Theater unter Windows™.

Fenster-Menü

Überlappend
Nebeneinander
Übereinander

Die geöffneten Spielfenster werden überlappend, nebeneinander oder übereinander neu angeordnet.

Alle Verkleinern

Verkleinert alle Spielfenster zur Titelleiste.

Alle Wiederherstellen

Stellt die vorhergehende Anordnung der Spielfenster wieder her.

Titelleisten ordnen

Ordnet alle Titelleisten auf dem Desktop des Rahmenfensters neu.

Schließen!

Beendet das aktuelle Programm und schließt das Spielfenster.

Alle Schließen!

Beendet alle laufenden Programme und schließt alle Spielfenster.

Fensterliste

In der sich anschließenden Liste werden alle Spielfenster aufgeführt.

Theater-Menü

Sprache >

Wählen Sie hier die Sprache für die Theater-Menüs und für die Informationstexte innerhalb von Messageboxen. Alle neuen Programme werden mit dieser Sprache gestartet.

Anm: Nur die Basismenüs von Theater besitzen die Menüpunkte zur Auswahl der Theatersprache.

Sprache > Hilfetext

Bestimmt die Sprache für den HTML-Hilfetext und der Beschreibung der Dialogfenster.
Für „andere“ können noch weitere HTML Hilfetexte unter dem Dateinamen Theater4_0_other.chm eingebunden werden.

Erläuterungen

Öffnet einen Hilfetext mit Erläuterungen zu jk-ware Theater.

Menübefehle

Aktiviert diesen Hilfetext.

über...

Zeigt eine Dialogbox mit Informationen zu jk-ware Theater und Copyrights an.

Nach oben


Theater_agif.htm

HTML-Hilfe für jk-ware Theater 4.0